Environment Deployment

SuperMap iDesktopX has a built-in extension development template (SampleCodeTemplates). After configuring JDK and the development environment, decompress this template in the product package/templates directory and perform simple configuration to quickly start extension development.

Install JDK

SuperMap iDesktopX is compatible with JDK8 and JDK17, and JDK8 is recommended as the default choice. When you need to experience the new canvas style, please upgrade to JDK 17 for the best effect. The following will take JDK8 as an example to introduce specific installation and configuration steps.

  1. Download JDK8: Download the JDK8 compressed package according to the hardware system.

  2. Decompress the JDK8 compressed package, for example:

  3. Set system environment variables:
    1. Open the computer's system environment variables setting dialog.
    2. In the System Variables group, create a new JAVA_HOME variable with the value as the decompression path of the JDK compressed package, such as "D:\soft\JDK8\openlogic-openjdk-8u462-b08-windows-x64".

    3. In the System Variables group, create a new CLASSPATH variable with the value: %JAVA_HOME%\lib\dt.jar;%JAVA_HOME%\lib\tools.jar;

    4. Add %JAVA_HOME%\bin to the Path system variable.

Install IDEA

The recommended development tool is IDEA, and it is advised to install IDEA version 2024.2 or higher. The following uses version 2025.2.3 as an example to introduce the installation and configuration of IDEA.

  1. After downloading the IntelliJ IDEA Community Edition software from the IDEA official website, double-click the downloaded .exe file to install it.

  2. Set the JDK environment of the Project to 8. As shown below: In File->Project Structure->Project->SDK, select 1.8 from the drop-down list.

Development Project Configuration

Recommended Method

Directly use the New Custom Development Project function in the View tab to build a secondary development project. This method is efficient and convenient, requiring no manual addition of desktop dependencies, and allows you to choose the storage path for the development project and customize project parameters; it can also import secondary development sample code, facilitating users to quickly start extension development.

  1. New Custom Development Project: Click the View tab -> Custom group -> New Custom Development Project button, and in the popped-up dialog, set the project name, version, author, template type, storage path, etc., according to the prompts. Among them,
    • Template Type: Provides two types: CtrlAction and GPA. CtrlAction is used to extend basic desktop functions, and GPA is used to extend tools in the toolbox.
    • Import Secondary Development Sample Code: When selected, the secondary development sample code provided in the software package can be imported into the newly created project. When starting the project, the desktop will simultaneously load the Sample Code tab.

  2. Open Project to IDEA: After creating a new project, a dialog will pop up asking whether to open IDEA. Click Yes to proceed. Or, in the output window, click Open the project to directly jump to IDEA. As shown below, the SampleCode directory is the new project.
    • If the import secondary development sample code option is checked, the secondary development sample template directory SampleCodeTemplates will also be loaded in the project.
    • If IDEA does not open automatically, please manually start the IDEA program and use the IDEA->File->Open function to select and open the newly created project directory.

  3. Select the Corresponding Startup Configuration for the JDK Environment: If the JDK environment is 1.8, choose the MyStartUp startup configuration; if the JDK environment is 17, choose MyStartUp_JDK17.

  4. Compile: Click the Run or Debug button on the IDEA toolbar to start compilation. After successful compilation, SuperMap iDesktopX will automatically start, and a Secondary Development tab will be added to the Ribbon.
    • If GPA is selected as the Template Type, a GPA Tool Examples group will be added to the Secondary Development tab and the toolbox, including two example tools: Delete Duplicate Points and Set Coordinate System.
      Figure: Secondary Development Tab Figure: Toolbox
    • If the Import Secondary Development Sample Code checkbox is selected, a Sample Code tab will also be added to the Ribbon.

Other Methods

Directly open the extension development sample template in IDEA. This method requires manually adding dependencies.

  1. Decompress the Sample Template Compressed Package: Decompress the SampleCodeTemplates.zip compressed package in the product package\templates directory.

  2. Open the Template Project: IDEA->File->Open->Select the product package\templates\SampleCodeTemplates directory and open the extension development sample template project.

  3. Add Desktop Dependencies:
    1. Select File->Project Structure->Libraries->Add->Java button.
    2. In the popped-up Select Library Files dialog, select the %SuperMap iDesktopX product package%/bin folder.
    3. In the popped-up Choose Module dialog, select the module that needs dependencies added, then click OK to complete the dependency addition.
    4. Repeat the above steps to continue adding the following dependencies:
      • %SuperMap iDesktopX product package%/bundles/idesktop_bundles/
      • %SuperMap iDesktopX product package%/bundles/require_bundles/
      • %SuperMap iDesktopX product package%/lib/
      • %SuperMap iDesktopX product package%/lib/Jars/
      • %SuperMap iDesktopX product package%/support/batJars/bdt-all-runtime.jar
      • %SuperMap iDesktopX product package%/support/browser/

  4. Select the Corresponding Startup Configuration for the JDK Environment: If the JDK environment is 1.8, choose the MyStartUp startup configuration; if the JDK environment is 17, choose MyStartUp_JDK17.
  5. Compile: Click the Run or Debug button on the IDEA toolbar to start compilation. After successful compilation, SuperMap iDesktopX will automatically start.

Related Topics

Project Template

Plugin Configuration Overview

Interface Configuration

Ribbon Configuration

Start Menu Configuration

Configure Status Bar

Configure Context Menu

Configure Dock Bars

Attributes