常见问题解答

问题1:无法正常访问 SuperMap iPortal AI助理接口UI页面

操作步骤 服务部署完成后,访问 http://[IP地址]:8080/swagger-ui/index.html 页面,页面异常
问题现象
问题原因 许可只有一套,导致SuperMap iPortal AI助理服务无法正确使用许可
解决方案 增加申请的Web试用许可套数,如64套,配置许可时注意按套配置

问题2:访问SuperMap iPortal AI助理首页,提示网络连接异常

操作步骤 服务部署完成后,访问 http://[IP地址]/iportal/apps/copilot/index.html,页面报“网络连接异常”错误
问题现象
问题原因
  1. SuperMap iPortal AI助理服务无法正确连接Web许可
  2. 浏览器外部访问无法通过iPortal AI助理服务名称来连接
  3. SuperMap iPortal AI助理服务的端口30002被iserver-ftp服务占用
解决方案
  1. SuperMap iPortal AI助理 服务启动脚本的BSLICENSE_SERVER参数,要填写对应许可服务IP
  2. 将ai-copilot\web\values.yaml文件的服务名称改为IP,确保浏览器可以访问

  3. 将ai-copilot\web\values.yaml和ai-copilot\server\values.yaml两个文件里的30002端口改为30092,再重新部署

问题3:在 SuperMap iPortal AI助理提问后,没有回复响应

操作步骤 在对话窗口输入指令并发送,没有任何响应回复
问题现象
问题原因
  1. ai-copilot-server-service服务不正常
  2. Qwen模型不存在,模型名称多了一层目录
解决方案
  1. 将application-app.yml文件内容、磁盘路径、容器目录修改正确
  2. 将nlp-aiagent\values.yaml文件的"Qwen/Qwen2.5-7B-Instruct"改为"Qwen2.5-7B-Instruct",再重新部署

问题4:SuperMap iPortal AI助理 统计资源失败,提示“调用resource_search工具失败”

操作步骤 输入资源统计指令并发生,提示“调用resource_search工具失败”
问题现象
问题原因 SuperMap iPortal 是root用户启动,root用户无法成功启动es,故而无法使用 SuperMap iPortal 检索功能
解决方案 Linux系统创建一个平台用户,将 SuperMap iPortal 目录赋予给普通用户执行权,重启 SuperMap iPortal
# 添加用户 yb,密码 yb
adduser yb
# iPortal目录所属赋予给yb用户
chown yb:yb -R supermap-iportal-12.0.0-250217-7982-linux64-deploy
# iportal目录给与yb用户执行权限
chmod 777 -R supermap-iportal-12.0.0-250217-7982-linux64-deploy
# SuperMap iPortal 重启

问题5:在 SuperMap iPortal AI助理中上传Excel文件失败

操作步骤 在 SuperMap iPortal AI助理中上传文件,选择Excel文件
问题现象
问题原因 SuperMap iPortal 解析Excel数据后需要存储到关系型数据库中,但是 SuperMap iPortal 未配置关系型数据库
解决方案 在SuperMap iPortal 中配置关系型数据库

问题6:SuperMap iPortal AI助理 数资源可视化显示失败,提示坐标系不一致

操作步骤 SuperMap iPortal AI助理中4326的点数资源可视化显示失败,提示底图坐标系为3857,不能绘制地图
问题现象
问题原因 SuperMap iPortal 有多个底图,默认用了3857坐标系,导致与4326数据不匹配
解决方案 将提示词改为更精准,告诉SuperMap iPortal AI助理 该数据和什么坐标系底图叠加上图显示

问题7:bslicense服务启动失败

操作步骤 用sh startup.sh后台启动许可服务报错
问题现象
问题原因 sh脚本写法错误
解决方案 用 ./startup.sh 命令启动Web许可服务

问题8:SuperMap iPortal AI助理微服务部署时,安装gpu-operator失败

操作步骤 SuperMap iPortal AI助理微服务部署时,执行命令安装gpu-operator后,查看对应的镜像服务不是running状态。
helm install --wait --generate-name -n gpu-operator --create-namespace nvidia/gpu-operator
问题现象
问题原因 通过k8s页面查看对应Pod的日志,提示镜像无法拉取,不存在
解决方案
  1. 根据镜像名称在网上找到镜像源地址,手动拉取镜像并修改名称
  2. docker pull registry.k8s.io/nfd/node-feature-discovery:v0.16.6swr.cn-north-4.myhuaweicloud.com/ddn-k8s/registry.k8s.io/nfd/node-feature-discovery:v0.16.6cn-north-4.myhuaweicloud.com/ddn-k8s/registry.k8s.io/nfd/node-feature-discovery:v0.16.6
    docker tag  swr.cn-north-4.myhuaweicloud.com/ddn-k8s/registry.k8s.io/nfd/node-feature-discovery:v0.16.6  registry.k8s.io/nfd/node-feature-discovery:v0.16.6
  3. 也可通过页面编辑Pod配置,修改镜像源在线拉取,保持名称一致即可
  4. 镜像比较大,拉取耗时,需要耐心等待pod变为running状态,在查看状态即可

问题9:SuperMap iPortal AI助理发出指令后,提示数据不规范,无法解析

操作步骤 SuperMap iPortal AI助理发出指令后,提示“已获取到工具的返回结果,但返回结果的数据格式不规范,我无法做解析。请你自行查看response body的内容”
问题现象
问题原因 用的DeepSeek模型,其函数调用能力比较差,不如Qwen模型
解决方案 将Deepseek模型换为Qwen模型重新部署即可解决,当前 SuperMap iPortal AI助理产品正在适配Deepseek模型

问题10:SuperMap iPortal AI助理中可以用什么指令,将两个地图类型的资源叠加到一张地图中可视化显示

解决方案
  1. 用指令检索出两个资源的ID:“检索名称为xxx和xxx的资源详情”
  2. 用指令根据ID将地图叠加显示:以ID“1920356928和ID”为底图,将ID为“384415761”的资源一起可视化显示

问题11:启动模型微调服务时,报错端口被占用

解决方案 由于之前启动NLP服务时宿主机占用了8000端口,如果还需启动微调服务端口可在启动命令中修改。修改后的命令:
docker run --network nlp --name nlp-fine-tune-service -dit --gpus all -p 8001:8000 -p 8080:8080 -p 32741:32741 -p 32742:32742 -v /opt/dongyixin/db:/opt/db -v /opt/models/modelscope:/root/.cache/modelscope -e BSLICENSE_SERVER=ws://bslicense-server:9183registry.cn-chengdu.aliyuncs.com/supermap-ai/nlp-fine-tune:12.0.0-beta

问题12:SuperMap iPortal 注册服务后,服务访问正常,在资源应用中心里看不到该服务

解决方案
  1. 停掉SuperMap iPortal ,编辑SuperMap iPortal 的\webapps\iportal\WEB-INF目录下的iportal.xml配置文件
  2. 把配置文件中的< reindexAllResources >参数修改为true
  3. 重启SuperMap iPortal后即可解决问题