| Q1: | What causes the failure to open or create when using Oracle data sources through the desktop on Linux systems? |
| A: |
This phenomenon is due to not setting the Oracle environment variables. The solution is: Before starting SuperMap iDesktopX each time, temporarily set the Oracle client to the environment variables in the Terminal. For example, set the environment variables via a profile file. Write the following commands to the profile file, then execute source profile in the Terminal. After setting the Oracle client environment variables, restart SuperMap iDesktopX in the same Terminal to use Oracle data sources normally. To create or connect to an Oracle data source, you need to configure the Oracle client in the environment where the desktop is running, add the client to LD_LIBRARY_PATH. A profile example can be provided, and configure tnsnames.ora; if using EZConnect for connection, tnsnames configuration may not be necessary. |
| Q2: | When adding image files from an FTP server to a mosaic dataset, and the FTP server path contains non-English characters, resulting in failure, how to handle it? |
| A: |
The mosaic dataset supports managing image files from FTP servers. If the FTP path of the image files contains non-English characters, adding them to the mosaic dataset may fail. The reason is that the encoding of the FTP client is inconsistent with the encoding used by the server, causing the FTP server path to be incorrectly transcoded, making the image files inaccessible. Therefore, when encountering this situation, you need to obtain the real download path of the FTP server path containing non-English characters. For example: The FTP server path is: ftp://127.0.0.1/image data/dem30米分辨率.tif, and its corresponding real download path is: ftp://127.0.0.1/%E5%BD%B1%E5%83%8F%E6%95%B0%E6%8D%AE/dem30%E7%B1%B3%E5%88%86%E8%BE%A8%E7%8E%87.tif. How to obtain the real download path of the FTP server path:
|
| Q3: |
Open Web Datasource, XYZTile service opens as a white map. |
| A: |
Please confirm if the entered URL is correct: (1) Confirm if the placeholders {x}{y}{z} in the request are correct. Currently, only {zoom} or {z}, {x}, {y} or {-y} are supported; other forms of placeholders are not supported. (2) Confirm the tile size in the current service. If it is not 256, you need to add a tile size parameter tilesize=*** to the URL. |
